GET STARTED

Inherited Budgets missing

Implemented

Comments

10 comments

  • Avatar
    dev

    Hi Lukas,

    This is known issue for the time being, we are working on a fix. 

    Budgets will be corrected soon within several hours, I will update you additionally.

     

    Budgets 500 error will be investigated too.

    Maxim Lutsan

    0
    Comment actions Permalink
  • Avatar
    dev

    Hi Lukas,

    The first issue is resolved, budget should be properly displayed.

    The 500 error is still under investigation, it will take some additional time.

     

    Maxim Lutsan

    0
    Comment actions Permalink
  • Avatar
    Lukas Tynek

    Hi Maxim, 

    thanks for your quick reaction. We can see our budgets in time explorer, thank you,  but we cannot still see them in API 

    for example:

    https://cisvsts.timehub.7pace.com/api/odata/TimeExport(StartDate='2019-10-04',EndDate='2019-12-11',PopulateTopParentColumns=null,GroupTimeByDateByUser=null,IncludeBillable=null)?$select=RowID,TFSID,UserEmail,Budget,BudgetHours,DurationInSeconds,TrackedTimeType,TeamMember, ActivityType,ApprovalState,Comment,BudgetClosed, InheritedBudget, UserID&$filter=tfsid eq 77896

    Thanks, Lukas

     

     

    0
    Comment actions Permalink
  • Avatar
    dev

    Hi Lukas,

    We identified some more issues in new API 3.0 and as we powered 2.1 with new API behind: it can also affect 2.1.

     

    The quickest workaround will be temporarily switching new Reporting feature for your organization and when we fix and roll out everything: we will enable it back. What would you say?

     

    Maxim Lutsan

    0
    Comment actions Permalink
  • Avatar
    Lukas Tynek

    Hi Maxim,

    yes, you can rollback the version. Reports loaded from API are important for management. 

    Thanks, Lukas

    0
    Comment actions Permalink
  • Avatar
    dev

    We rolled it back, but this is cached in the app memory, to reset it please navigate to Settings open any setting and click "Apply" without changing anything.

     

    Maxim Lutsan

    0
    Comment actions Permalink
  • Avatar
    Lukas Tynek

    Thank you, now seems me everything is working.

     

    Thanks, Lukas

    0
    Comment actions Permalink
  • Avatar
    dev

    Hello, Lukas!

    We enabled reporting for your organization again. Can you check please if everything OK?

    0
    Comment actions Permalink
  • Avatar
    Lukas Tynek

    Hi, 

    probably it needs to enable API 3.0.  Everything seems working, except tab reporting.

     

    Thanks, Lukas

    0
    Comment actions Permalink
  • Avatar
    dev

    Hello, Lukas!

     

    Sorry for this. We just enabled API 3.0 for you.

     

    Best Regards

    Dmitrii Vavel

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk