customFields import in powerBi

Officially Answered

Comments

9 comments

  • Avatar
    Maxim (Andarth) Shestakov

    Hi!

    To check what fields are available in your environment please open the following link:
    https://dev.azure.com/{ORG_NAME}/_apis/wit/fields
    that will return json data with all fields, find the one you want and use referenceName property to use in PowerBI
    Please let me know if this can help you.

    Regards,
    Maxim

    0
    Comment actions Permalink
  • Avatar
    Nikolaj Vestergaard Hansen

    It works for me with some custom fields, but not all. 

    I use 

    https://ascenddevops.timehub.7pace.com/api/odata/v3.0/workItemsHierarchy?customFields=Custom.ParentEpic

    And get

    Details: "Microsoft.Mashup.Engine1.Library.Resources.HttpResource: Request failed:
    OData Version: 3 and 4, Error: The remote server returned an error: (500) Internal Server Error.
    OData Version: 4, Error: The remote server returned an error: (500) Internal Server Error.
    OData Version: 3, Error: The remote server returned an error: (400) Bad Request."

     

    It is in my json of fields:

    {
    "name": "Parent Epic",
    "referenceName": "Custom.ParentEpic",
    "description": "Enter the ID number of the parent Epic",
    "type": "integer",
    "usage": "workItem",
    "readOnly": false,
    "canSortBy": true,
    "isQueryable": true,
    "supportedOperations": [
    {
    "referenceName": "SupportedOperations.Equals",
    "name": "="
    },
    {
    "referenceName": "SupportedOperations.NotEquals",
    "name": "<>"
    },
    {
    "referenceName": "SupportedOperations.GreaterThan",
    "name": ">"
    },
    {
    "referenceName": "SupportedOperations.LessThan",
    "name": "<"
    },
    {
    "referenceName": "SupportedOperations.GreaterThanEquals",
    "name": ">="
    },
    {
    "referenceName": "SupportedOperations.LessThanEquals",
    "name": "<="
    },
    {
    "referenceName": "SupportedOperations.In",
    "name": "In"
    },
    {
    "name": "Not In"
    },
    {
    "referenceName": "SupportedOperations.Ever",
    "name": "Was Ever"
    },
    {
    "referenceName": "SupportedOperations.EqualsField",
    "name": "= [Field]"
    },
    {
    "referenceName": "SupportedOperations.NotEqualsField",
    "name": "<> [Field]"
    },
    {
    "referenceName": "SupportedOperations.GreaterThanField",
    "name": "> [Field]"
    },
    {
    "referenceName": "SupportedOperations.LessThanField",
    "name": "< [Field]"
    },
    {
    "referenceName": "SupportedOperations.GreaterThanEqualsField",
    "name": ">= [Field]"
    },
    {
    "referenceName": "SupportedOperations.LessThanEqualsField",
    "name": "<= [Field]"
    }
    ],
    "isIdentity": false,
    "isPicklist": false,
    "isPicklistSuggested": false,
    "url": "https://dev.azure.com/AscendDevOps/_apis/wit/fields/Custom.ParentEpic"
    },

     

    0
    Comment actions Permalink
  • Avatar
    Maxim (Andarth) Shestakov

    Thanks for these details.
    Could you please try to perform this request (https://ascenddevops.timehub.7pace.com/api/odata/v3.0/workItemsHierarchy?customFields=Custom.ParentEpic) via Postman (https://www.getpostman.com/downloads/) and send us error message details from it (as PowerBI doesn't return error details)

    Regards,
    Maxim

    0
    Comment actions Permalink
  • Avatar
    Nikolaj Vestergaard Hansen

    After generating a new API Token to use getpostman, everything seems to be working, also in PBI. Mabye it was just the Friday jitters :-)

    0
    Comment actions Permalink
  • Avatar
    Maxim (Andarth) Shestakov

    Thanks for this update.

    Great to hear that the issue was resolved!

    Regards,
    Maxim

    0
    Comment actions Permalink
  • Avatar
    dev

    I think the reason can be following: list of fields are not immediately available in Timetracker after you add them into DevOps. We cache them (to reduce load on all systems) once per 24 hours.

     

    Maxim Lutsan

    0
    Comment actions Permalink
  • Avatar
    Hans ter Wal

    Hi Maxim,

     

    Is there a way to reset the cache for an account? Im trying to setup a demo for our management with some custom fields I just added in a test setup account.

     

    Regards,

     

    Hans

    0
    Comment actions Permalink
  • Avatar
    dev

    Hi Hans,

    Yes, please navigate to Settings -> Reporting & REST API -> Restart Reporting, that will do the job.

     

    Maxim Lutsan

    0
    Comment actions Permalink
  • Avatar
    Hans ter Wal

    Hi Maxim,

     

    Thank you works like a charm.

     

    Hans

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk